CentOS 4.4에서 OpenManage 사용 못하나요?

서버와 스토리지

서버와 스토리지
가장 효과적인 비즈니스 솔루션을 찾고 계시다면 여기서 서버와 스토리지에 관한 해답을 얻으세요.

CentOS 4.4에서 OpenManage 사용 못하나요?

  • 회사에서 레드햇 리눅스(서버용)랑 Cent OS 4.4를 사용하는데요, 레드햇 리눅스는 지원되는 운영체제라고 오픈매니지가 설치되더라구요. 근데 CentOS는 설치가 안되던데 혹시 설치 성공해보신 분 계시나요?
    알고 있기로는 cent os나 레드햇이나 거의 같은 운영체제로 알고 있는 데 왜 설치가 안되나요?
     
    이게 설치안되서 서버를 원격에서 관리를 못하고 이따는... ㅠㅠ
  • 여기 게시판은 게시물 수정이 안되나요? --;;
     
    서버는 파워엣지 2950이랑 2900, 1950 입니다.
     
     
  • 제가 알기로는 CentOS는 RedHat Enterprise server의 소스를 그대로 copy 해서 사용하므로 기능상으로 큰 차이는 없으나, 특정 Application에서는 Licence 정책상 release name 등 몇가지 고유한 이름을 인증하는 구문을 불러와 일치 할 때 설치를 진행하는 것 같습니다.
    install script만 피하면 수동으로도 설치는 가능한데요,
     
    쉽게 설치하는 방법이 있어 공유합니다.
     
    델에서는 인증 또는 비 인증된 OS의 사용자를 위해 yum repository를 별도로 운영하더군요.
     
    즉 yum 으로 자동으로 설치가 가능하다는 것입니다.
     
    아래 URL 참조하시고
     
     
    핵심만 말씀드리면
     
    #wget -q -O - http://linux.dell.com/repo/hardware/bootstrap.cgi | bash 
     
    진행하면 뭐라뭐라 하면서 HW 정보를 불러들이는 패키지를 설치하겠느냔 메시지 나옵니다.
    Yes 로 설치 하고
     
    #yum install srvadmin-all 을 실행합니다.
    패키지 네임 불러오면 성공.
     
    혹시 못불러 오면, 기존에 Centos base repository 가 cache 걸려 있어서 새로운 repository를 불러 오지 못해서 입니다.
     
    이럴경우
     
    #yum clean all 이라고 입력 해 보세요.
     
    cache가 지워지는 메시지를 받았다면,
     
    #service yum restart -yum service 재시작을 한 후
     
    위 과정을 다시 한번 해 보세요.
     
    참고로, dell에서 제공하는 repository root에는 OMSA 5.2까지만 현재 올라와 있습니다.
     
    최신버젼 5.3 은 yum 으로 설치 할 수 없습니다. 
     
    5.3은 Perc6을 사용할 때 storage 정보를 불러들입니다. perc5 까지는 yum으로 설치하시면 됩니다.
     
    그럼. 좋은 결과가 있기를 바랍니다.  
  • 아참
     
    한가지가 빠졌습니다.
     
    캐시 지우고, 새 repository 불러 올때
     
    #yum clean all
     
    과 함께 /etc/yum.conf 파일에 plugins=1 을 추가로 기입해 주셔야 제대로 먹습니다.
     
    yum 데몬 리스타트 있지 마시구요...~
  • 우왓! 너무 감사감사!!!
     
    잘 되네요!!
  • 안녕하세요?

    귀하의 답변은 FAQ로 등록되었습니다.

     


    좋은 답변 감사합니다.
  •  
     
     
    2008년 2월 26일 부로 dell 의 yum repository 에 OMSA 5.3 이 올라왔네요.
     
    이젠 perc6 까지 지원되는 버젼을 yum으로 설치 가능하겠어요.